关键词不能为空

当前您在: 主页 > 主页 > 股市市场 >

条件选股公式的编写_数学_自然科学_专业资料营口港股票

作者:今天股市行情
来源:https://www.hnkaiping.cn/hnka
【更新日期】2021-10-24 00:51:56
摘要:摩根士丹利华鑫-玻璃钢制品有限公司 2021年4月7日发(作者:合众思壮(002383)合众思壮) 条件选股公式的编写 】对于改写选股公式特发虎年学习贴-----终结篇(也就 是高级篇)!!!!!

摩根士丹利华鑫-玻璃钢制品有限

2021年4月7日发(作者:合众思壮(002383)合众思壮)
条件选股公式的编写

】对于改写选股公式特发虎年学习贴-----终结篇(也就
是高级篇)!!!!!
2011-01-28 14:42:51| 分类: 公式收集 | 标签: |字号
大中小 订阅


对于改写选股公式特发虎年学习贴-----终结篇(也就是高级
篇)!!!!!
一、条件选股公式的编写
什么是条件选股?
简单讲,就是按照您设定的条件用电脑帮助您完成一些太多
太复杂的挑选--比如您有一些好的心得和,可是有1300
多只股票,您就是有100双眼睛有时也不一定可以看得过来,
这时条件选股公式+电脑就派上用场了!
编写条件选股公式其实很简单,它是在技术公式的基础上编
写而成的,我们还可以将任意一个技术指标公式改写成选股
公式。值得注意的是,选股公式与技术公式的区别是它只有
一个返回值,通俗的讲就是选股公式只有一个不带“=”号的语
句,其它语句都要有“=”号,否则在测试时会提示选股公式
必须只有一个返回值,如图:
好了,我们开始建立一个选股公式。点击”条件选股“选项,
选择”新建“,开始编写,写完后给指标起个名字,点击测试
通过后保存。我们举例来说明:
{龙行KDJ}
RSV:=(CLOSE-LLV(LOW,7))(HHV(HIGH,7)-LLV(LOW,7))
*100;
短K:SMA(RSV,3,1),COLORFF00FF;
短D:SMA(短K,3,1),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,38))(HHV(HIGH,38)-LLV(LO
W,38))*100;
长K:SMA(RSV1,5,1),COLORRED;
长D:SMA(长K,10,1),COLOR66CC33;
18,COLORWHITE;
85,COLORBLUE;
STICKLINE(短K>短D,短K,短D,4,0),COLORYELLOW;
STICKLINE(短K<=短D,短K,短D,4,0),COLORGREEN;
STICKLINE(长K>长D,长K,长D,4,0),COLORRED;
STICKLINE(长K<=长D,长K,长D,4,0),COLOR6933;
上面是《龙行KDJ》技术指标,根据这个指标改编成选股指
标。
{龙行短线选股}
RSV:=(CLOSE-LLV(LOW,7))(HHV(HIGH,7)-LLV(LOW,7))
*100;
短K:=SMA(RSV,3,1);
短D:=SMA(短K,3,1);
cross(短K,短D)
{配合龙行kdj指标使用}
{龙行长线选股}
RSV:=(CLOSE-LLV(LOW,38))(HHV(HIGH,38)-LLV(LOW,
38))*100;
长K:=SMA(RSV1,5,1);
长D:=SMA(长K,10,1);
cross(长K,长D)
{配合龙行KDJ指标使用}
看明白了吧!我们把一个技术指标改编成了2个选股指标,
而且每个只用了4条语句就OK啦!那么我们就可以开始选
股啦,把选出的股票存放在大智慧自选1板块里,用龙行
KDJ技术指标对照比较一下,看看选出的股票走势都是在技
术指标的什么位置上,是处在低位还是处在阶段低位,你就
可以根据判断择机介入了。凡是用技术指标改编的选股公式
建议你都这样做。
条件选股的优势在于语句少、速度快,凡是符合条件的股票
一个不漏的选出来存放在自选1或自选2等自定义的板块里
供你挑选。下面选择一些各种走势特征和形态特征的指标供
朋友参考。
一、放量、缩量(成交量函数为VOL)
1、放量:
(1).今天成交量较昨天了1倍,表示如下:
VOLREF(VOL,1)>2
(2).今天成交量较10个交易日平均成交量放大了1倍,表
示如下:
a:=ma(vol,10);
Vola>2
或者直接用如下公式表示:
volma(vol,10)>2;
(3).今日的5日均量较10个交易日平均成交量放大了1倍,
表示如下:
a:=ma(vol,10);
b:=ma(vol,5);
ba>2;
(4).今日的成交量超过了整个流通盘的5%,表示如下:
volcapital>0.05;{其中capital代表流通盘。}
2、缩量
(1).今日成交量较昨日了一半,表示如下:
volref(vol,1)<0.5;
(2).今日成交量较10个交易日平均成交量一倍,表示
如下:
a:=ma(vol,10);
vola<2;
或者直接用如下公式表示:
volma(vol,10)<2;
(3).今日的5日均量较10个交易日平均成交量1倍,
表示如下:
a:=ma(vol,10);
b:=ref(a,5);
ab<2;
(4).今日的成交量低于了整个流通盘的5%,表示如下:
volcapital<0.05;
二、上涨、下跌
上涨:
今天的涨幅达到5%以上,表示如下:
closeref(close,1)>1.05;
5日均价连续上涨,表示如下:
a:=ma(close,5);
b:=ref(a,1);
b;
下跌:
今天的跌幅达到5%以上,表示如下:
closeref(close,1)<0.95;
5日均价连续下跌,表示如下:
a:=ma(close,5);
b:=ref(a,1);
a<b;
(3)、K线的描述
close>open;阳线
close<open;阴线
open>ref(close,1);高开
open<ref(close,1);低开
open>ref(high,1);跳空高开(high为价)
open<ref(low,1);跳空低开(low为最低价)
三、走势特征选股公式的编制
(1)、n日内创新高
hhv(high,n)=hhv(high,0) and barscount(c)>=n;
注:n为指标参数,可在参数设定范围内设定参数范围。
Hhv(x,n),求n周期内x值,n=0则从第一个有效值开
始;barscount(x),将当前位置到n周期前的数值设为1,若x
非0,则将当前位置到n周期前的数值设为1。
(2)、n日内创新低
llv(low,n)=llv(low,0) and barscount(close)>=n;
注n为指标参数,可在参数设定范围内设定参数范围。
Llv(x,n),求n周期内x最低值,n=0则从第一个有效值开始;
barscount(x)第一个有效数据到当前的天数,例如,
barscount(close)以于日线数据取得上市以来总交易日数。
(3)、n日内阴线多于阳线
count(open>close,n)n<0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定阴线占
全部K线个数的比例)。
(4)、n日内阳线多于阴线
count(open<close,n)n>0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定阳线占
全部K线个数的比例)。
(5)、n日内上涨多于下跌(第二天开盘高于前一天收盘)
count(c>ref(c,1),n)n>0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定其中比
例)。
(6)、n日内上涨少于下跌(第二天开盘低于前一天收盘)
count(c>ref(c,1),n)n<0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定其中比
例)。
(7)、连续n日收阳线
up:=close>open;
count(up,n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。n为指标参数,可在参数设定范围
内设定参数范围。
(8)、连续n日内收阴线
up:=close<open;
count(up,n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(9)、连续n天上涨
count(close>ref(close,1),n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(10)、连续n天下跌
count(c<ref(c,1),n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(11)、首次创新高

barssince(c>hhv(if(barscount(c)=1,high,0),0))+1=1;
注:barscount(x),若x非0,则将当前位置到n周期前的数
值设为1。
(12)、创历史新高
hhv(close,0)=close;
注:hhv(x,n),求n周期内x值,n=0则从第一个有效
值开始。
(13)、创历史新低
llv(close,0)=close;
注:llv(x,n),求n周期内x最小值,n=0则从第一个有效值
开始。
(14)、单日放量
a:=ref(ma(vol,5),1);
vola>n and volcapital*100>m;
注:n为指标参数,代表今日成交量和前一日的5日均量的
比值,可在参数设定范围内设定参数范围。
(15)、阶段缩量
sum(vol,n1)capital<=n2;
注:n1为要统计的阶段时间,n2为缩量比例,可在参数设
定范围内设定参数范围。
(16)、阶段放量
sum(vol,n1)capital>=n2;
注:n1为要统计的阶段时间,n2为y放量比例,可在参数
设定范围内设定参数范围。
(17)、放量
a:=vol>ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日放大,n为要
统计的阶段时间,可在参数设定范围内设定参数范围。
(18)、缩量
a:=vol<ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日缩小,n为要
统计的阶段时间,可在参数设定范围内设定参数范围。
(19)、间隔放量
a:=ma(vol,5);
barscount(c)>=n and hhv(a,n)<n1*llv(a,n) and
count(vol>n2*a,n)>n3;
注:unt(x)第一个有效数据到当前的天数。
Barscount(c)对于日线数据取得上市以来总交易日数。
b.完整含义:n日内五日均量的最大值小于最小值的n1倍,
成交量大于等于五日均量的n2倍的情况发生的多于n3
次。
(20)、放量上攻
a:=(c-ref(c,1))ref(c,1)>=(n100);
sum(vol,n1)capital>=(n2100) and
count(vol>ref(vol,1),n3 )=n3 and count(a,n3)=n3;
完整含义:每日股价涨幅均大于n%,n1日内累计换手率大
于n2%,并且成交量连续在n3日内放大。
(21)、温和放量上攻
股价小幅上扬
a1:=closeref(close,1);
a2:=a1>1 and a1<1.03;
成交量小幅上扬
b1:=volref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)capital<0.05;
count(a2 and b2,n)n>0.6 and c1;
完整公式为:
a1:=closeref(close,1);
a2:=a1>1 and a1<1.03;
b1:=volref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)capital<0.05;
count(a2 and b2,n)n>0.6 and c1;
注:公式分为股价小幅上扬和成交量小幅上扬两个部分,请
在指标编写时注意其结构。
(22)、突然放量
vol>ref(hhv(vol,n),1*m;
注:当前成交量高于n个周期中最大成交量的m倍。
(23)、平台整理
count(close,0)>n and
(hhv(close,n)-llv(close,n))llv(close,n)<=(n1100);
注:count(close,0)>n为平台整理n个周期的设定。
(hhv(close,n)-llv(close,n))llv(close,n)<=(n1100)为平台
整理幅度n1%的设定。
(24)、突破盘整
ref(((hhv(h,n)-llv(l,n))llv(l,n))llv(l,n)),1)<=(n1100)
and c>=ref(hhv(h,n),1) and barscount(c)>n;
注:前n日在上下n1%的幅度内整理:
ref(((hhv(h,n)-llv(l,n))llv(l,n))llv(l,n)),1)<=(n1100);
今日突破:c>=ref(hhv(h,n),1)。
(25)、阶段强势股
a:=sum(if(date-n=0,indexc,0),0);
b:=sum(if(date-n1=0,indexc,0)0);
e:=sum(if(date-n=0,c,0),0);
f:=sum(if(date-n1=0,c,0),0);
((f-e)e)>((b-a)a);
注:该公式求的是n日-n1日之间涨幅高于大盘的股票。n、
n1参数的表达格式为yymmdd,注意在2000年前的表达为
年份的后两位,例如1999年为99,从2000年开始以100
依次向后累加,例如2001年9月14日为,indexc
函数表示同期大盘的收盘价,该函数对分笔成交周期无
效。
(26)、阶段弱势股
a:=sum(if(date=n,indexc,0),0);
b:=sum(if(date=n1,indexc,0)0);
e:=sum(if(date=n,c,0),0);
f:=sum(if(date=n1,c,0),0);
((f-e)e)<((b-a)a);
注:该公式求的是n日-n1日之间涨幅低于大盘的股票。n、
n1参数的表达格式为yymmdd,注意在2000年前的表达为
年份的后两位,例如1999年为99,从2000年开始以100
依次向后累加,例如2001年9月14日为,indexc
函数表示同期大盘的收盘价,该函数对分笔成交周期无
效。
(27)、大盘同步
count((c>o and indexc>indexo) or (c<o and
indexc<indexo),n)n>m100;
注:含义为n周期中与大盘走势相同(同收阴线或同收阳线)
的例超过m%。此处的o不是数字的零,而是开盘价open
的首写字母o。
(28)、n日内强势股
a:=(c-ref(o,n))ref(o,n);
b:=(indexc-ref(indexo,n))ref(indexo,n);
a>b and ab>=m;
注:n日内个股涨幅大于等于大盘涨幅的m倍。
四、形态特征选股公式的编制
(1)、均线多头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2 and a2>a3 and a3>a4,3)=3 and
isup;
注:n1、n2、n3、n4j日均线呈多头排列,isup也可以用
close>open表示。
(2)、均线空头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<a2 and a2<a3 and a3<a4,3)=3 and
not(isup);
注:n1、n2、n3、n4j日均线呈空头排列,isup也可以用
close<open表示。
(3)、早晨之星
ref(close,2)ref(open,2<0.95 and
ref(open,1)<ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.03 and
closeopen>1.05 and close>ref(close,2);
注:早晨之星,这种形态和叫法自然是后市向好,为买进信
号。早晨之星由三根K线组成,其顺序是:
第一天在下跌中已形成一根阴线:
ref(close,2)ref(open,2<0.95
第二天呈裂口下跌,K线实体较短,构成星的主体部分,
阴线或阳线均可,有无上下影线均不重要。
ref(open,1)<ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.03
关键是第三根K线必须是阳线,且其长度至少要升至
第一根阴线实体(如果能够“包容”第一根阴线则最好不过了)
closeopen>1.05 and close>ref(close,2)
(4)、强势整理
a1:=abs(close-open)open<0.015;
a2:=count(a,m)=m;
a3:=ref(o,m)<ref(c,m) and ref
(c,m)ref(c,m+1)>1+n100;
a2 and a3;
注:一根实体超过n的长阳,后面跟m个K线实体不超过
1.5%的K线。
(5)、高开大阴线
open>close and openref(c,1)>=1+m100 and
closeopen<=1-n100;
注:跳空高开m%,当日股价较开盘价跌幅大于n。股价经
过一段攀升之后,某一日突然跳高开盘:
openref(c,1)>=1+m100
后股价一路下行,尾市以接近最低点收市:
closeopen<=1-n100
此出现,往往意味着股价已形成短期头部,应注
意回避风险。
(6)、低开大阳线
open<close and openref(c,1)<=1-m100 and
closeopen>=1+n100;
注:跳空低开m%,当日股价较开盘价涨幅大于n,其他描
述请参见(5)。
(7)、黄昏之星
ref(close,2)ref(open,2)>1.03 and
ref(open,1)>ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.02 and
closeopen<0.97 and close<ref(close,2);
注:黄昏之星表示股价回落,是卖出,应伺机抛货。幕
星同样由三根K线组成,其形态和晨星正好相反:
第一天股价继续上升,拉出一根阳线:
ref(close,2)ref(open,2)>1.03
第二天波动较小,形成一根小阳线或小阴线,构成星
的主体部分:
ref(open,1)>ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.02
第三天形成一根包容第二天并延伸至第一天阳线实
体:
closeopen<0.97 and close<ref(close,2)
(8)、跳空缺口
high<ref(low,1) or low>ref(high,1);
注:从内容上看,分别是向下跳空缺口和向上跳空缺口。
(9)、均线金叉
a;=ma(c,5);
b:=ma(c,10);
cross(a,b);
注:前二句是5、10日均线,cross是交叉函数,cross(a,b)
表示5日均线与10日均线金叉。
(10)、均线死叉
a;=ma(c,5);
b:=ma(c,10);
cross(b,a);
注:前二句是5、10日均线,cross是交叉函数,cross(b,a)
表示5日均线与10日均线死叉。
(11)、均线粘合
ma1:=ma(c,5);
ma2:=ma(c,10),
ma3:=ma(c,20);
p1:=abs(ma1-ma2)+abs(ma2-ma3);
p1c<m100 and ma1>ref(ma1,1) and
ma2>ref(ma2,1);
注:前三句是三根均线,p1是第一根均线减第二根均线差的
绝对值与第二根均线减第三根均线差的绝对值之和,最后一
句是p1与收盘价的比值小于一定比率m%(一般该比率为2%
以下,同时前二均线今日比昨日上翘。
二、装饰指标小
我们在网上下载指标时,往往帖图上漂亮的指标画面
最吸引人们的眼球,下载的人也多,点击率也高,可见,爱
美之心,人皆有之。由此说明,在不影响使用的前提下,为
什么不把指标做的漂亮一点呢!想想看,漂亮的指标显示在
主图或副图上,不仅调节了视觉效果,也调节了沉闷的心情,
何乐而不为呢!好了,下面我们就装饰一个指标。
装饰指标最常用的是绘图函数、线形函数和颜代码。我们
选一个最常用最熟悉的指标KDJ。
装饰前
RSV:=(CLOSE-LLV(LOW,9))(HHV(HIGH,9)-LLV(LOW,9))
*100;
K:SMA(RSV,3,1),colorwhite;
D:SMA(K,3,1),coloryellow;
J:3*K-2*D,colorff00ff;
装饰后
RSV:=(CLOSE-LLV(LOW,9))(HHV(HIGH,9)-LLV(LOW,9))
*100;
K:SMA(RSV,3,1),colorwhite;
D:SMA(K,3,1),coloryellow;
J:3*K-2*D,colorff00ff;
a1:=cross(k,d) and c>o and k<60;{KD在坐标线60以
下金叉并且收阳线}
a2:=cross(j,90);{j大于90超买}
STICKLINE(j>k,j,k,4,0),colorwhite;{条件J大于K,在J
线与K线之间画宽度为4的白柱线}
STICKLINE(j<k,j,k,4,0),colorff00ff;{条件J小于K,在J线
与K线之间画宽度为4的粉柱线}
STICKLINE(k>d,k,d,4,0),colorred;{条件K大于D,在K
线与D线之间画宽度为4的红柱线}
STICKLINE(k<d,k,d,4,0),color00ff00;{条件K小于D,在K
线与D线之间画宽度为4的绿柱线}
STICKLINE(a1,50,0,4,0),coloryellow;{赋值A1,在0至50
坐标之间画宽度为4的黄柱线}
STICKLINE(a2,110,105,8,0),color00ff00;{赋值A2,在110
至105坐标之间画宽度为8的绿柱线}
80,colorred,pointdot;
20,colorffcccc,pointdot;
看看效果是不是很漂亮。还可以在指标添加文字、红脸、绿
脸、平脸和各种特殊符号等,由你尽可能的发挥想象。
编写不止这些,仅在此列举这几个例子,算是抛砖引玉吧。
-----------------------
背景装饰小
飞狐、家股软能将背景颜通过渐变颜函数装扮的很
漂亮,那么大智慧股软能做到吗?能,但做出的背景虽不
如飞狐、家漂亮,也能起到装扮的作用,效果也可
以。
在大智慧设计背景的原理主要是通过主、副图的坐标用画
柱线函数STICKLINE或者设定坐标用颜代码就可以完成。
下面用实例来说明背景的设计。
一、单背景,这是最简单实用的一种装饰。我们先
来设计一个主图指标:
要领:1、设定坐标:
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;意
思是CLOSE>0条件时,在坐标h*9.0至坐标l*0.01
处画宽度为8的实体柱线(也就是在整个主图上添)。
也可以这样设定STICKLINE(110,0,110,8,0),color7d7f0f;显
示的是同样效果。
2、添的源码必须在指标的头条位置上,否则会覆盖均线、
K线、文字等图形。
3、必须另外编制K线,因为背景会覆盖系统中的K线图。
4、可以把背景分为五档、十挡或更多,同时注意与你的
指标的最大值、最小值(也就是坐标)相匹配,否则会在指标
中出现背景残缺不全的情况。
5、用你喜欢的颜需要结合调器可随意自定义自己喜欢
的颜。不过可得有耐心啊!
指标示例一:
{多空密码主图}
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;{设
置背景,可以将这句源码复制粘贴到任意主图指标的头条位
置上}
Var1:=(3*CLOSE+LOW+OPEN+HIGH)6;
Var3:=(20*Var1+19*REF(Var1,1)+18*REF(Var1,2)+17*RE
F(Var1,3)+16*REF(Var1,4)+15*REF
(Var1,5)+14*REF(Var1,6)+13*REF(Var1,7)+12*REF(Var1,
8)+11*REF(Var1,9)+10*REF
(Var1,10)+9*REF(Var1,11)+8*REF(Var1,12)+7*REF(Var1,
13)+6*REF(Var1,14)+5*REF
(Var1,15)+4*REF(Var1,16)+3*REF(Var1,17)+2*REF(Var1,
18)+REF(Var1,20))221;
Var4:=MA(Var3,78),LINETHICK2;
Var5:=EMA(MA(CLOSE,3),34);
Var6:=MA(Var3,5);
Var7:=MA(Var3,9);
M60:MA(C,60),COLOREEFFFF,CIRCLEDOT;
STICKLINE(Var3>1.005*Var4,Var3,Var4,4,1),COLORY
ELLOW;
STICKLINE(IF(Var3<Var5,Var3<=1.015*Var4,Var3<
=1.005*Var4),Var7,Var4,2,1),COLORffff88;
STICKLINE(Var3>Var6,Var3,Var7,4,1),COLORff88ff;
STICKLINE(IF(Var3<Var6,Var3<=1.015*Var6,Var3<
=1.005*Var6),Var3,Var7,3,1),COLORFF6633;
STICKLINE(Var3>Var6,Var3,Var7,4,1),COLOR0000ff;
{下面是柱形K线,如果喜欢这样的K线,你可以复制粘贴
到任意主图指标里面}
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),colorffcc66;
STICKLINE(C<=O,H,L,0,0),colorffcc66;
M9:MA(C,9),COLORYELLOW;
生命线: MA(CLOSE,13),COLORYELLOW,LINETHICK2;
牛熊线:
(EMA(CLOSE,5)*7+EMA(CLOSE,5)*3)10,COLORFF00C
C,LINETHICK2;
箱顶:MA(REF(HHV(CLOSE,30),1),2);
箱底:MA(REF(LLV(CLOSE,30),1),2);
AAMA(C,13)+MA(C,21)+MA(C,34)+MA(C,55))4,COLORF
F00FF;
半年线:ma(close,125),colorffcc66;
指标示例二:
{财面副图}
VAR2:=(CLOSE-LLV(LOW,20))(HHV(HIGH,20)-LLV(LO
W,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)28.57;
VAR4:=EMA(VAR3,5);
操盘:=3*VAR3-2*VAR4;
A1:=CROSS(操盘,VAR3) AND VAR3<2.1 and c>o;
40,colorred,pointdot;
STICKLINE(c>0,40,22,8,0),colorff8080;{设置背
景,CLOSE>0条件时,在坐标40至坐标22处设置
宽度为8的兰背景}
STICKLINE(c>0,22,4,8,0),color916f87;{设置背
景,CLOSE>0条件时,在坐标22至坐标4处设置宽
度为8的深紫背景}
stickline(a1,18,15,28,0),colorred;
stickline(a1,18,18,18,0),colorblue;
stickline(a1,8,8,9,0),colorffff00;
stickline(a1,6,6,4,0),colorffff00;
stickline(a1,10,10,12,0),colorffff00;
stickline(a1,12,12,20,0),colorffff00;
stickline(a1,14,14,24,0),colorffff00;
stickline(a1,16,34,0.1,0),colorc0c0c0;
stickline(a1,33,18,9,0),colorwhite;
drawtext(a1,36,&#39;财面
&#39;),COLORWHITE;
VarE:=30+(REF(CLOSE,1)-REF(OPEN,1))REF(OPEN,1)
*1001.5;
VarF:=30+(REF(CLOSE,2)-REF(OPEN,2))REF(OPEN,2)*
1001.5;
Var10:=CROSS(

Var11:=CROSS(REF(
),1)) AND REF(
Var12:=CROSS(REF(
),2)) AND REF(
Var13:=Var10 OR Var11 OR Var12;
Var14:=REF(
Var15:=REF(
AND REF(
AND Var13 AND Var14;
卖出:=Var15*,color00ff00;
stickline(卖出,18,15,28,0),coloryellow;
stickline(卖出,18,18,18,0),colorblue;
stickline(卖出,8,8,9,0),colorffff00;
stickline(卖出,6,6,4,0),colorffff00;
stickline(卖出,10,10,12,0),colorffff00;
stickline(卖出,12,12,20,0),colorffff00;
stickline(卖出,14,14,24,0),colorffff00;
stickline(卖出,16,28,0.1,0),colorc0c0c0;
stickline(卖出,28,18,9,0),color00ff00;
drawtext(卖出,31,&#39;落袋为安
&#39;),COLOR00FF00;
指标示例三:
{金叉死叉}
STICKLINE(100,0,100,8,0),colorff0098;{设置背景,100条件
时,在坐标100至坐标0处设置宽度为8的紫兰背景}
Var1:=EMA(HHV(HIGH,500),21);
Var2:=EMA(HHV(HIGH,250),21);
Var3:=EMA(HHV(HIGH,90),21);
Var4:=EMA(LLV(LOW,500),21);
Var5:=EMA(LLV(LOW,250),21);
Var6:=EMA(LLV(LOW,90),21);
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558
+Var2*0.558+Var3*0.558)6,21);
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+
Var2*0.55+Var3*0.65)6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var
2*0.68+Var3*0.68)6,21);
VarA:=EMA((Var7*3+Var8*2+Var9)6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)SMA(MAX(LOW-VarB,
0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC10),
3);
VarE:=LLV(LOW,30);
VarF:=HHV(VarD,30);
Var10:=IF(MA(CLOSE,58),1,0);
Var11:=EMA(IF(LOW<=VarE,(VarD+VarF*2)2,0),3)618
*Var10;
Var12:=IF(Var11>40,10,Var11);
STICKLINE(Var12>8,0,Var12,4,1), , COLORFF00FF;
Var13:=HHV(HIGH,30);
Var14:=LLV(LOW,30);
能量
K:EMA((CLOSE-Var14)(Var13-Var14)*97,5),COLORRED
,linethick2;
能量
D:EMA((CLOSE-Var14)(Var13-Var14)*100,15),linethick2,
colorff9933;
底部峰:5,pointdot,linethick2,COLORFF00FF;
DRAWTEXT(CROSS(底部峰,能量K),能量
d,&#39;●&#39;),COLORWHITE;
DRAWTEXT(CROSS(底部峰,能量K),能量K+15,&#39;
底部形成&#39;),COLORWHITE;
大智慧:100,,pointdot,linethick2,color00ccff;
强弱分界:50,pointdot,COLORWHITE;
DRAWTEXT(CROSS(90,能量
K),80,&#39;●&#39;),COLOR00FF00;
DRAWTEXT(CROSS(90,能量K),90,&#39;有风险
&#39;),COLOR00FF00;
DRAWTEXT(CROSS(90,能量K),能量
K+13,&#39;●&#39;),COLOR00FF00;
DRAWTEXT(CROSS(能量D,能量K),98,&#39;死叉
&#39;),COLORFFCC66;
DRAWTEXT(CROSS(能量D,能量
K),90,&#39;●&#39;),COLORFFCC66;
DRAWTEXT(CROSS(能量K,能量D),8,&#39;金叉
&#39;),COLORYELLOW;
DRAWTEXT(CROSS(能量K,能量
D),15,&#39;●&#39;),COLORYELLOW;
0,pointdot,linethick2,COLORFF00FF;
渐变源码供参考:
STICKLINE(0 ,0,-1,15,0) ,COLORFF0098;
STICKLINE(10 ,10,0,15,0) ,COLORFF009A;
STICKLINE(20 ,20,10,15,0),COLORFF009C;
STICKLINE(30 ,30,20,15,0),COLORFF009E;
STICKLINE(40 ,40,30,15,0),COLORFF00A0;
STICKLINE(50 ,50,40,15,0),COLORFF00A2;
STICKLINE(60 ,60,50,15,0),COLORFF00A4;
STICKLINE(70 ,70,60,15,0),COLORFF00A6;
STICKLINE(80 ,80,70,15,0),COLORFF00A8;
STICKLINE(90 ,90,80,15,0),COLORFF00AA;
STICKLINE(100 ,100,90,15,0),COLORFF00AC;
STICKLINE(110 ,110,100,15,0),COLORFF00AF;
单源码供参考:
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;
K线
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),colorffcc66;
STICKLINE(C<=O,H,L,0,0),colorffcc66;
副图背景源码供参考:
STICKLINE(100,0,100,8,0),color7d7f0f;{注意指标的坐标,
按不同的坐标做相应的,本例是100的坐标}
三、 引用指标小
我们在编写各种指标时经常引用其他指标,如果直接把要
引用的指标全都写下来,不但了工作量,而且了指
标的长度。有没有方便简单的呢?有,这就是把股软系
统内的指标通过一定的按你的需要加以引用。
1、引用技术指标公式
引用技术指标的指标线,写法是公式名称.指标线名称参
数),注意:所引用的指标必须是系统内有的,否则不能引用,
也不能通过测试。参数表中的参数个数应该与被引用公式的
实际参数量一致。例如:,表示引用根据(9,3,3)
参数计算出KDJ指标中的K指标线数值。公式示例:
{顶底背离}
顶底背离:0,COLORYELLOW;
A1:=BARSLAST(ref(cross(

B1:=ref(c,A1+1)>c and
ref(
cross(
MACD底背
离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGR
EEN;
DRAWTEXT(FILTER(B1>0,5),0.57,&#39;MACD底
背离&#39;),COLORGREEN;
A2:=BARSLAST(ref(cross(
B2:=ref(c,A2+1)>c and
ref(
cross(
KDJ底背
离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELL
OW;
DRAWTEXT(FILTER(B2>0,5),0.80,&#39;KDJ底背
离&#39;),COLORYELLOW;
A3:=BARSLAST(ref(cross(
(6,12,24)),1));
B3:=ref(c,A3+1)>c and
ref(
cross(
RSI底背
离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORFFC
C66;
DRAWTEXT(FILTER(B3>0,5),0.25,&#39;RSI底背
离&#39;),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(ref(cross(

D1:=ref(c,C1+1)<c and ref(

条件选股公式的编写

】对于改写选股公式特发虎年学习贴-----终结篇(也就
是高级篇)!!!!!
2011-01-28 14:42:51| 分类: 公式收集 | 标签: |字号
大中小 订阅


对于改写选股公式特发虎年学习贴-----终结篇(也就是高级
篇)!!!!!
一、条件选股公式的编写
什么是条件选股?
简单讲,就是按照您设定的条件用电脑帮助您完成一些太多
太复杂的挑选--比如您有一些好的心得和,可是有1300
多只股票,您就是有100双眼睛有时也不一定可以看得过来,
这时条件选股公式+电脑就派上用场了!
编写条件选股公式其实很简单,它是在技术公式的基础上编
写而成的,我们还可以将任意一个技术指标公式改写成选股
公式。值得注意的是,选股公式与技术公式的区别是它只有
一个返回值,通俗的讲就是选股公式只有一个不带“=”号的语
句,其它语句都要有“=”号,否则在测试时会提示选股公式
必须只有一个返回值,如图:
好了,我们开始建立一个选股公式。点击”条件选股“选项,
选择”新建“,开始编写,写完后给指标起个名字,点击测试
通过后保存。我们举例来说明:
{龙行KDJ}
RSV:=(CLOSE-LLV(LOW,7))(HHV(HIGH,7)-LLV(LOW,7))
*100;
短K:SMA(RSV,3,1),COLORFF00FF;
短D:SMA(短K,3,1),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,38))(HHV(HIGH,38)-LLV(LO
W,38))*100;
长K:SMA(RSV1,5,1),COLORRED;
长D:SMA(长K,10,1),COLOR66CC33;
18,COLORWHITE;
85,COLORBLUE;
STICKLINE(短K>短D,短K,短D,4,0),COLORYELLOW;
STICKLINE(短K<=短D,短K,短D,4,0),COLORGREEN;
STICKLINE(长K>长D,长K,长D,4,0),COLORRED;
STICKLINE(长K<=长D,长K,长D,4,0),COLOR6933;
上面是《龙行KDJ》技术指标,根据这个指标改编成选股指
标。
{龙行短线选股}
RSV:=(CLOSE-LLV(LOW,7))(HHV(HIGH,7)-LLV(LOW,7))
*100;
短K:=SMA(RSV,3,1);
短D:=SMA(短K,3,1);
cross(短K,短D)
{配合龙行kdj指标使用}
{龙行长线选股}
RSV:=(CLOSE-LLV(LOW,38))(HHV(HIGH,38)-LLV(LOW,
38))*100;
长K:=SMA(RSV1,5,1);
长D:=SMA(长K,10,1);
cross(长K,长D)
{配合龙行KDJ指标使用}
看明白了吧!我们把一个技术指标改编成了2个选股指标,
而且每个只用了4条语句就OK啦!那么我们就可以开始选
股啦,把选出的股票存放在大智慧自选1板块里,用龙行
KDJ技术指标对照比较一下,看看选出的股票走势都是在技
术指标的什么位置上,是处在低位还是处在阶段低位,你就
可以根据判断择机介入了。凡是用技术指标改编的选股公式
建议你都这样做。
条件选股的优势在于语句少、速度快,凡是符合条件的股票
一个不漏的选出来存放在自选1或自选2等自定义的板块里
供你挑选。下面选择一些各种走势特征和形态特征的指标供
朋友参考。
一、放量、缩量(成交量函数为VOL)
1、放量:
(1).今天成交量较昨天了1倍,表示如下:
VOLREF(VOL,1)>2
(2).今天成交量较10个交易日平均成交量放大了1倍,表
示如下:
a:=ma(vol,10);
Vola>2
或者直接用如下公式表示:
volma(vol,10)>2;
(3).今日的5日均量较10个交易日平均成交量放大了1倍,
表示如下:
a:=ma(vol,10);
b:=ma(vol,5);
ba>2;
(4).今日的成交量超过了整个流通盘的5%,表示如下:
volcapital>0.05;{其中capital代表流通盘。}
2、缩量
(1).今日成交量较昨日了一半,表示如下:
volref(vol,1)<0.5;
(2).今日成交量较10个交易日平均成交量一倍,表示
如下:
a:=ma(vol,10);
vola<2;
或者直接用如下公式表示:
volma(vol,10)<2;
(3).今日的5日均量较10个交易日平均成交量1倍,
表示如下:
a:=ma(vol,10);
b:=ref(a,5);
ab<2;
(4).今日的成交量低于了整个流通盘的5%,表示如下:
volcapital<0.05;
二、上涨、下跌
上涨:
今天的涨幅达到5%以上,表示如下:
closeref(close,1)>1.05;
5日均价连续上涨,表示如下:
a:=ma(close,5);
b:=ref(a,1);
b;
下跌:
今天的跌幅达到5%以上,表示如下:
closeref(close,1)<0.95;
5日均价连续下跌,表示如下:
a:=ma(close,5);
b:=ref(a,1);
a<b;
(3)、K线的描述
close>open;阳线
close<open;阴线
open>ref(close,1);高开
open<ref(close,1);低开
open>ref(high,1);跳空高开(high为价)
open<ref(low,1);跳空低开(low为最低价)
三、走势特征选股公式的编制
(1)、n日内创新高
hhv(high,n)=hhv(high,0) and barscount(c)>=n;
注:n为指标参数,可在参数设定范围内设定参数范围。
Hhv(x,n),求n周期内x值,n=0则从第一个有效值开
始;barscount(x),将当前位置到n周期前的数值设为1,若x
非0,则将当前位置到n周期前的数值设为1。
(2)、n日内创新低
llv(low,n)=llv(low,0) and barscount(close)>=n;
注n为指标参数,可在参数设定范围内设定参数范围。
Llv(x,n),求n周期内x最低值,n=0则从第一个有效值开始;
barscount(x)第一个有效数据到当前的天数,例如,
barscount(close)以于日线数据取得上市以来总交易日数。
(3)、n日内阴线多于阳线
count(open>close,n)n<0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定阴线占
全部K线个数的比例)。
(4)、n日内阳线多于阴线
count(open<close,n)n>0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定阳线占
全部K线个数的比例)。
(5)、n日内上涨多于下跌(第二天开盘高于前一天收盘)
count(c>ref(c,1),n)n>0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定其中比
例)。
(6)、n日内上涨少于下跌(第二天开盘低于前一天收盘)
count(c>ref(c,1),n)n<0.5;
注:n为指标参数,可在参数设定范围内设定参数范围。同
时可以自由编辑里面的数值(如0.5等 ,达到确定其中比
例)。
(7)、连续n日收阳线
up:=close>open;
count(up,n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。n为指标参数,可在参数设定范围
内设定参数范围。
(8)、连续n日内收阴线
up:=close<open;
count(up,n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(9)、连续n天上涨
count(close>ref(close,1),n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(10)、连续n天下跌
count(c<ref(c,1),n)=n;
注:count(x,n),统计n周期中x条件的周期数,若n=0
则从第一个有效值开始。N为指标参数,可在参数设定范围
内设定参数范围。
(11)、首次创新高

barssince(c>hhv(if(barscount(c)=1,high,0),0))+1=1;
注:barscount(x),若x非0,则将当前位置到n周期前的数
值设为1。
(12)、创历史新高
hhv(close,0)=close;
注:hhv(x,n),求n周期内x值,n=0则从第一个有效
值开始。
(13)、创历史新低
llv(close,0)=close;
注:llv(x,n),求n周期内x最小值,n=0则从第一个有效值
开始。
(14)、单日放量
a:=ref(ma(vol,5),1);
vola>n and volcapital*100>m;
注:n为指标参数,代表今日成交量和前一日的5日均量的
比值,可在参数设定范围内设定参数范围。
(15)、阶段缩量
sum(vol,n1)capital<=n2;
注:n1为要统计的阶段时间,n2为缩量比例,可在参数设
定范围内设定参数范围。
(16)、阶段放量
sum(vol,n1)capital>=n2;
注:n1为要统计的阶段时间,n2为y放量比例,可在参数
设定范围内设定参数范围。
(17)、放量
a:=vol>ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日放大,n为要
统计的阶段时间,可在参数设定范围内设定参数范围。
(18)、缩量
a:=vol<ref(vol,1);
count(a,n)=n;
注:其中条件a的含义为成交量较上一交易日缩小,n为要
统计的阶段时间,可在参数设定范围内设定参数范围。
(19)、间隔放量
a:=ma(vol,5);
barscount(c)>=n and hhv(a,n)<n1*llv(a,n) and
count(vol>n2*a,n)>n3;
注:unt(x)第一个有效数据到当前的天数。
Barscount(c)对于日线数据取得上市以来总交易日数。
b.完整含义:n日内五日均量的最大值小于最小值的n1倍,
成交量大于等于五日均量的n2倍的情况发生的多于n3
次。
(20)、放量上攻
a:=(c-ref(c,1))ref(c,1)>=(n100);
sum(vol,n1)capital>=(n2100) and
count(vol>ref(vol,1),n3 )=n3 and count(a,n3)=n3;
完整含义:每日股价涨幅均大于n%,n1日内累计换手率大
于n2%,并且成交量连续在n3日内放大。
(21)、温和放量上攻
股价小幅上扬
a1:=closeref(close,1);
a2:=a1>1 and a1<1.03;
成交量小幅上扬
b1:=volref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)capital<0.05;
count(a2 and b2,n)n>0.6 and c1;
完整公式为:
a1:=closeref(close,1);
a2:=a1>1 and a1<1.03;
b1:=volref(vol,1);
b2:=b1>1 and b1<2;
c1:=ma(vol,n)capital<0.05;
count(a2 and b2,n)n>0.6 and c1;
注:公式分为股价小幅上扬和成交量小幅上扬两个部分,请
在指标编写时注意其结构。
(22)、突然放量
vol>ref(hhv(vol,n),1*m;
注:当前成交量高于n个周期中最大成交量的m倍。
(23)、平台整理
count(close,0)>n and
(hhv(close,n)-llv(close,n))llv(close,n)<=(n1100);
注:count(close,0)>n为平台整理n个周期的设定。
(hhv(close,n)-llv(close,n))llv(close,n)<=(n1100)为平台
整理幅度n1%的设定。
(24)、突破盘整
ref(((hhv(h,n)-llv(l,n))llv(l,n))llv(l,n)),1)<=(n1100)
and c>=ref(hhv(h,n),1) and barscount(c)>n;
注:前n日在上下n1%的幅度内整理:
ref(((hhv(h,n)-llv(l,n))llv(l,n))llv(l,n)),1)<=(n1100);
今日突破:c>=ref(hhv(h,n),1)。
(25)、阶段强势股
a:=sum(if(date-n=0,indexc,0),0);
b:=sum(if(date-n1=0,indexc,0)0);
e:=sum(if(date-n=0,c,0),0);
f:=sum(if(date-n1=0,c,0),0);
((f-e)e)>((b-a)a);
注:该公式求的是n日-n1日之间涨幅高于大盘的股票。n、
n1参数的表达格式为yymmdd,注意在2000年前的表达为
年份的后两位,例如1999年为99,从2000年开始以100
依次向后累加,例如2001年9月14日为,indexc
函数表示同期大盘的收盘价,该函数对分笔成交周期无
效。
(26)、阶段弱势股
a:=sum(if(date=n,indexc,0),0);
b:=sum(if(date=n1,indexc,0)0);
e:=sum(if(date=n,c,0),0);
f:=sum(if(date=n1,c,0),0);
((f-e)e)<((b-a)a);
注:该公式求的是n日-n1日之间涨幅低于大盘的股票。n、
n1参数的表达格式为yymmdd,注意在2000年前的表达为
年份的后两位,例如1999年为99,从2000年开始以100
依次向后累加,例如2001年9月14日为,indexc
函数表示同期大盘的收盘价,该函数对分笔成交周期无
效。
(27)、大盘同步
count((c>o and indexc>indexo) or (c<o and
indexc<indexo),n)n>m100;
注:含义为n周期中与大盘走势相同(同收阴线或同收阳线)
的例超过m%。此处的o不是数字的零,而是开盘价open
的首写字母o。
(28)、n日内强势股
a:=(c-ref(o,n))ref(o,n);
b:=(indexc-ref(indexo,n))ref(indexo,n);
a>b and ab>=m;
注:n日内个股涨幅大于等于大盘涨幅的m倍。
四、形态特征选股公式的编制
(1)、均线多头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1>a2 and a2>a3 and a3>a4,3)=3 and
isup;
注:n1、n2、n3、n4j日均线呈多头排列,isup也可以用
close>open表示。
(2)、均线空头排列
a1:=ma(c,n1);
a2:=ma(c,n2);
a3:=ma(c,n3);
a4:=ma(c,n4);
count(a1<a2 and a2<a3 and a3<a4,3)=3 and
not(isup);
注:n1、n2、n3、n4j日均线呈空头排列,isup也可以用
close<open表示。
(3)、早晨之星
ref(close,2)ref(open,2<0.95 and
ref(open,1)<ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.03 and
closeopen>1.05 and close>ref(close,2);
注:早晨之星,这种形态和叫法自然是后市向好,为买进信
号。早晨之星由三根K线组成,其顺序是:
第一天在下跌中已形成一根阴线:
ref(close,2)ref(open,2<0.95
第二天呈裂口下跌,K线实体较短,构成星的主体部分,
阴线或阳线均可,有无上下影线均不重要。
ref(open,1)<ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.03
关键是第三根K线必须是阳线,且其长度至少要升至
第一根阴线实体(如果能够“包容”第一根阴线则最好不过了)
closeopen>1.05 and close>ref(close,2)
(4)、强势整理
a1:=abs(close-open)open<0.015;
a2:=count(a,m)=m;
a3:=ref(o,m)<ref(c,m) and ref
(c,m)ref(c,m+1)>1+n100;
a2 and a3;
注:一根实体超过n的长阳,后面跟m个K线实体不超过
1.5%的K线。
(5)、高开大阴线
open>close and openref(c,1)>=1+m100 and
closeopen<=1-n100;
注:跳空高开m%,当日股价较开盘价跌幅大于n。股价经
过一段攀升之后,某一日突然跳高开盘:
openref(c,1)>=1+m100
后股价一路下行,尾市以接近最低点收市:
closeopen<=1-n100
此出现,往往意味着股价已形成短期头部,应注
意回避风险。
(6)、低开大阳线
open<close and openref(c,1)<=1-m100 and
closeopen>=1+n100;
注:跳空低开m%,当日股价较开盘价涨幅大于n,其他描
述请参见(5)。
(7)、黄昏之星
ref(close,2)ref(open,2)>1.03 and
ref(open,1)>ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.02 and
closeopen<0.97 and close<ref(close,2);
注:黄昏之星表示股价回落,是卖出,应伺机抛货。幕
星同样由三根K线组成,其形态和晨星正好相反:
第一天股价继续上升,拉出一根阳线:
ref(close,2)ref(open,2)>1.03
第二天波动较小,形成一根小阳线或小阴线,构成星
的主体部分:
ref(open,1)>ref(close,2) and
abs(ref(open,1)-ref(close,1)ref(close,1)<0.02
第三天形成一根包容第二天并延伸至第一天阳线实
体:
closeopen<0.97 and close<ref(close,2)
(8)、跳空缺口
high<ref(low,1) or low>ref(high,1);
注:从内容上看,分别是向下跳空缺口和向上跳空缺口。
(9)、均线金叉
a;=ma(c,5);
b:=ma(c,10);
cross(a,b);
注:前二句是5、10日均线,cross是交叉函数,cross(a,b)
表示5日均线与10日均线金叉。
(10)、均线死叉
a;=ma(c,5);
b:=ma(c,10);
cross(b,a);
注:前二句是5、10日均线,cross是交叉函数,cross(b,a)
表示5日均线与10日均线死叉。
(11)、均线粘合
ma1:=ma(c,5);
ma2:=ma(c,10),
ma3:=ma(c,20);
p1:=abs(ma1-ma2)+abs(ma2-ma3);
p1c<m100 and ma1>ref(ma1,1) and
ma2>ref(ma2,1);
注:前三句是三根均线,p1是第一根均线减第二根均线差的
绝对值与第二根均线减第三根均线差的绝对值之和,最后一
句是p1与收盘价的比值小于一定比率m%(一般该比率为2%
以下,同时前二均线今日比昨日上翘。
二、装饰指标小
我们在网上下载指标时,往往帖图上漂亮的指标画面
最吸引人们的眼球,下载的人也多,点击率也高,可见,爱
美之心,人皆有之。由此说明,在不影响使用的前提下,为
什么不把指标做的漂亮一点呢!想想看,漂亮的指标显示在
主图或副图上,不仅调节了视觉效果,也调节了沉闷的心情,
何乐而不为呢!好了,下面我们就装饰一个指标。
装饰指标最常用的是绘图函数、线形函数和颜代码。我们
选一个最常用最熟悉的指标KDJ。
装饰前
RSV:=(CLOSE-LLV(LOW,9))(HHV(HIGH,9)-LLV(LOW,9))
*100;
K:SMA(RSV,3,1),colorwhite;
D:SMA(K,3,1),coloryellow;
J:3*K-2*D,colorff00ff;
装饰后
RSV:=(CLOSE-LLV(LOW,9))(HHV(HIGH,9)-LLV(LOW,9))
*100;
K:SMA(RSV,3,1),colorwhite;
D:SMA(K,3,1),coloryellow;
J:3*K-2*D,colorff00ff;
a1:=cross(k,d) and c>o and k<60;{KD在坐标线60以
下金叉并且收阳线}
a2:=cross(j,90);{j大于90超买}
STICKLINE(j>k,j,k,4,0),colorwhite;{条件J大于K,在J
线与K线之间画宽度为4的白柱线}
STICKLINE(j<k,j,k,4,0),colorff00ff;{条件J小于K,在J线
与K线之间画宽度为4的粉柱线}
STICKLINE(k>d,k,d,4,0),colorred;{条件K大于D,在K
线与D线之间画宽度为4的红柱线}
STICKLINE(k<d,k,d,4,0),color00ff00;{条件K小于D,在K
线与D线之间画宽度为4的绿柱线}
STICKLINE(a1,50,0,4,0),coloryellow;{赋值A1,在0至50
坐标之间画宽度为4的黄柱线}
STICKLINE(a2,110,105,8,0),color00ff00;{赋值A2,在110
至105坐标之间画宽度为8的绿柱线}
80,colorred,pointdot;
20,colorffcccc,pointdot;
看看效果是不是很漂亮。还可以在指标添加文字、红脸、绿
脸、平脸和各种特殊符号等,由你尽可能的发挥想象。
编写不止这些,仅在此列举这几个例子,算是抛砖引玉吧。
-----------------------
背景装饰小
飞狐、家股软能将背景颜通过渐变颜函数装扮的很
漂亮,那么大智慧股软能做到吗?能,但做出的背景虽不
如飞狐、家漂亮,也能起到装扮的作用,效果也可
以。
在大智慧设计背景的原理主要是通过主、副图的坐标用画
柱线函数STICKLINE或者设定坐标用颜代码就可以完成。
下面用实例来说明背景的设计。
一、单背景,这是最简单实用的一种装饰。我们先
来设计一个主图指标:
要领:1、设定坐标:
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;意
思是CLOSE>0条件时,在坐标h*9.0至坐标l*0.01
处画宽度为8的实体柱线(也就是在整个主图上添)。
也可以这样设定STICKLINE(110,0,110,8,0),color7d7f0f;显
示的是同样效果。
2、添的源码必须在指标的头条位置上,否则会覆盖均线、
K线、文字等图形。
3、必须另外编制K线,因为背景会覆盖系统中的K线图。
4、可以把背景分为五档、十挡或更多,同时注意与你的
指标的最大值、最小值(也就是坐标)相匹配,否则会在指标
中出现背景残缺不全的情况。
5、用你喜欢的颜需要结合调器可随意自定义自己喜欢
的颜。不过可得有耐心啊!
指标示例一:
{多空密码主图}
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;{设
置背景,可以将这句源码复制粘贴到任意主图指标的头条位
置上}
Var1:=(3*CLOSE+LOW+OPEN+HIGH)6;
Var3:=(20*Var1+19*REF(Var1,1)+18*REF(Var1,2)+17*RE
F(Var1,3)+16*REF(Var1,4)+15*REF
(Var1,5)+14*REF(Var1,6)+13*REF(Var1,7)+12*REF(Var1,
8)+11*REF(Var1,9)+10*REF
(Var1,10)+9*REF(Var1,11)+8*REF(Var1,12)+7*REF(Var1,
13)+6*REF(Var1,14)+5*REF
(Var1,15)+4*REF(Var1,16)+3*REF(Var1,17)+2*REF(Var1,
18)+REF(Var1,20))221;
Var4:=MA(Var3,78),LINETHICK2;
Var5:=EMA(MA(CLOSE,3),34);
Var6:=MA(Var3,5);
Var7:=MA(Var3,9);
M60:MA(C,60),COLOREEFFFF,CIRCLEDOT;
STICKLINE(Var3>1.005*Var4,Var3,Var4,4,1),COLORY
ELLOW;
STICKLINE(IF(Var3<Var5,Var3<=1.015*Var4,Var3<
=1.005*Var4),Var7,Var4,2,1),COLORffff88;
STICKLINE(Var3>Var6,Var3,Var7,4,1),COLORff88ff;
STICKLINE(IF(Var3<Var6,Var3<=1.015*Var6,Var3<
=1.005*Var6),Var3,Var7,3,1),COLORFF6633;
STICKLINE(Var3>Var6,Var3,Var7,4,1),COLOR0000ff;
{下面是柱形K线,如果喜欢这样的K线,你可以复制粘贴
到任意主图指标里面}
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),colorffcc66;
STICKLINE(C<=O,H,L,0,0),colorffcc66;
M9:MA(C,9),COLORYELLOW;
生命线: MA(CLOSE,13),COLORYELLOW,LINETHICK2;
牛熊线:
(EMA(CLOSE,5)*7+EMA(CLOSE,5)*3)10,COLORFF00C
C,LINETHICK2;
箱顶:MA(REF(HHV(CLOSE,30),1),2);
箱底:MA(REF(LLV(CLOSE,30),1),2);
AAMA(C,13)+MA(C,21)+MA(C,34)+MA(C,55))4,COLORF
F00FF;
半年线:ma(close,125),colorffcc66;
指标示例二:
{财面副图}
VAR2:=(CLOSE-LLV(LOW,20))(HHV(HIGH,20)-LLV(LO
W,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)28.57;
VAR4:=EMA(VAR3,5);
操盘:=3*VAR3-2*VAR4;
A1:=CROSS(操盘,VAR3) AND VAR3<2.1 and c>o;
40,colorred,pointdot;
STICKLINE(c>0,40,22,8,0),colorff8080;{设置背
景,CLOSE>0条件时,在坐标40至坐标22处设置
宽度为8的兰背景}
STICKLINE(c>0,22,4,8,0),color916f87;{设置背
景,CLOSE>0条件时,在坐标22至坐标4处设置宽
度为8的深紫背景}
stickline(a1,18,15,28,0),colorred;
stickline(a1,18,18,18,0),colorblue;
stickline(a1,8,8,9,0),colorffff00;
stickline(a1,6,6,4,0),colorffff00;
stickline(a1,10,10,12,0),colorffff00;
stickline(a1,12,12,20,0),colorffff00;
stickline(a1,14,14,24,0),colorffff00;
stickline(a1,16,34,0.1,0),colorc0c0c0;
stickline(a1,33,18,9,0),colorwhite;
drawtext(a1,36,&#39;财面
&#39;),COLORWHITE;
VarE:=30+(REF(CLOSE,1)-REF(OPEN,1))REF(OPEN,1)
*1001.5;
VarF:=30+(REF(CLOSE,2)-REF(OPEN,2))REF(OPEN,2)*
1001.5;
Var10:=CROSS(

Var11:=CROSS(REF(
),1)) AND REF(
Var12:=CROSS(REF(
),2)) AND REF(
Var13:=Var10 OR Var11 OR Var12;
Var14:=REF(
Var15:=REF(
AND REF(
AND Var13 AND Var14;
卖出:=Var15*,color00ff00;
stickline(卖出,18,15,28,0),coloryellow;
stickline(卖出,18,18,18,0),colorblue;
stickline(卖出,8,8,9,0),colorffff00;
stickline(卖出,6,6,4,0),colorffff00;
stickline(卖出,10,10,12,0),colorffff00;
stickline(卖出,12,12,20,0),colorffff00;
stickline(卖出,14,14,24,0),colorffff00;
stickline(卖出,16,28,0.1,0),colorc0c0c0;
stickline(卖出,28,18,9,0),color00ff00;
drawtext(卖出,31,&#39;落袋为安
&#39;),COLOR00FF00;
指标示例三:
{金叉死叉}
STICKLINE(100,0,100,8,0),colorff0098;{设置背景,100条件
时,在坐标100至坐标0处设置宽度为8的紫兰背景}
Var1:=EMA(HHV(HIGH,500),21);
Var2:=EMA(HHV(HIGH,250),21);
Var3:=EMA(HHV(HIGH,90),21);
Var4:=EMA(LLV(LOW,500),21);
Var5:=EMA(LLV(LOW,250),21);
Var6:=EMA(LLV(LOW,90),21);
Var7:=EMA((Var4*0.96+Var5*0.96+Var6*0.96+Var1*0.558
+Var2*0.558+Var3*0.558)6,21);
Var8:=EMA((Var4*1.25+Var5*1.23+Var6*1.2+Var1*0.55+
Var2*0.55+Var3*0.65)6,21);
Var9:=EMA((Var4*1.3+Var5*1.3+Var6*1.3+Var1*0.68+Var
2*0.68+Var3*0.68)6,21);
VarA:=EMA((Var7*3+Var8*2+Var9)6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)SMA(MAX(LOW-VarB,
0),3,1)*100;
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC10),
3);
VarE:=LLV(LOW,30);
VarF:=HHV(VarD,30);
Var10:=IF(MA(CLOSE,58),1,0);
Var11:=EMA(IF(LOW<=VarE,(VarD+VarF*2)2,0),3)618
*Var10;
Var12:=IF(Var11>40,10,Var11);
STICKLINE(Var12>8,0,Var12,4,1), , COLORFF00FF;
Var13:=HHV(HIGH,30);
Var14:=LLV(LOW,30);
能量
K:EMA((CLOSE-Var14)(Var13-Var14)*97,5),COLORRED
,linethick2;
能量
D:EMA((CLOSE-Var14)(Var13-Var14)*100,15),linethick2,
colorff9933;
底部峰:5,pointdot,linethick2,COLORFF00FF;
DRAWTEXT(CROSS(底部峰,能量K),能量
d,&#39;●&#39;),COLORWHITE;
DRAWTEXT(CROSS(底部峰,能量K),能量K+15,&#39;
底部形成&#39;),COLORWHITE;
大智慧:100,,pointdot,linethick2,color00ccff;
强弱分界:50,pointdot,COLORWHITE;
DRAWTEXT(CROSS(90,能量
K),80,&#39;●&#39;),COLOR00FF00;
DRAWTEXT(CROSS(90,能量K),90,&#39;有风险
&#39;),COLOR00FF00;
DRAWTEXT(CROSS(90,能量K),能量
K+13,&#39;●&#39;),COLOR00FF00;
DRAWTEXT(CROSS(能量D,能量K),98,&#39;死叉
&#39;),COLORFFCC66;
DRAWTEXT(CROSS(能量D,能量
K),90,&#39;●&#39;),COLORFFCC66;
DRAWTEXT(CROSS(能量K,能量D),8,&#39;金叉
&#39;),COLORYELLOW;
DRAWTEXT(CROSS(能量K,能量
D),15,&#39;●&#39;),COLORYELLOW;
0,pointdot,linethick2,COLORFF00FF;
渐变源码供参考:
STICKLINE(0 ,0,-1,15,0) ,COLORFF0098;
STICKLINE(10 ,10,0,15,0) ,COLORFF009A;
STICKLINE(20 ,20,10,15,0),COLORFF009C;
STICKLINE(30 ,30,20,15,0),COLORFF009E;
STICKLINE(40 ,40,30,15,0),COLORFF00A0;
STICKLINE(50 ,50,40,15,0),COLORFF00A2;
STICKLINE(60 ,60,50,15,0),COLORFF00A4;
STICKLINE(70 ,70,60,15,0),COLORFF00A6;
STICKLINE(80 ,80,70,15,0),COLORFF00A8;
STICKLINE(90 ,90,80,15,0),COLORFF00AA;
STICKLINE(100 ,100,90,15,0),COLORFF00AC;
STICKLINE(110 ,110,100,15,0),COLORFF00AF;
单源码供参考:
STICKLINE(CLOSE>0,h*9.0,l*0.01,8,0),color7d7f0f;
K线
STICKLINE(C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=O,C,O,4,0),COLOR7070ff;
STICKLINE(C>=O,C,O,2,0),COLORYELLOW;
STICKLINE(C>=O,H,L,0,0),COLORYELLOW;
STICKLINE(C<=O,C,O,7,0),COLORFF2020;
STICKLINE(C<=O,C,O,4,0),COLORFF6600;
STICKLINE(C<=O,C,O,2,0),colorffcc66;
STICKLINE(C<=O,H,L,0,0),colorffcc66;
副图背景源码供参考:
STICKLINE(100,0,100,8,0),color7d7f0f;{注意指标的坐标,
按不同的坐标做相应的,本例是100的坐标}
三、 引用指标小
我们在编写各种指标时经常引用其他指标,如果直接把要
引用的指标全都写下来,不但了工作量,而且了指
标的长度。有没有方便简单的呢?有,这就是把股软系
统内的指标通过一定的按你的需要加以引用。
1、引用技术指标公式
引用技术指标的指标线,写法是公式名称.指标线名称参
数),注意:所引用的指标必须是系统内有的,否则不能引用,
也不能通过测试。参数表中的参数个数应该与被引用公式的
实际参数量一致。例如:,表示引用根据(9,3,3)
参数计算出KDJ指标中的K指标线数值。公式示例:
{顶底背离}
顶底背离:0,COLORYELLOW;
A1:=BARSLAST(ref(cross(

B1:=ref(c,A1+1)>c and
ref(
cross(
MACD底背
离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGR
EEN;
DRAWTEXT(FILTER(B1>0,5),0.57,&#39;MACD底
背离&#39;),COLORGREEN;
A2:=BARSLAST(ref(cross(
B2:=ref(c,A2+1)>c and
ref(
cross(
KDJ底背
离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELL
OW;
DRAWTEXT(FILTER(B2>0,5),0.80,&#39;KDJ底背
离&#39;),COLORYELLOW;
A3:=BARSLAST(ref(cross(
(6,12,24)),1));
B3:=ref(c,A3+1)>c and
ref(
cross(
RSI底背
离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORFFC
C66;
DRAWTEXT(FILTER(B3>0,5),0.25,&#39;RSI底背
离&#39;),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(ref(cross(

D1:=ref(c,C1+1)<c and ref(

风声票房-在张江注册


咳喘宁口服液-海格集团


中天城投-南京高科置业有限


岳波-金川集团


berne-第三方支付


李光熙-中国联合


国内信用证-台山核电合营有限


苏宁易购官方旗舰店-伊利集团



Tags:

本文来自网络,不代表今天股市行情,转载请注明出处:https://www.hnkaiping.cn/hnka/100164.html
首发:2021-04-07 20:06

    上一篇:没有了
    下一篇:没有了

条件选股公式的编写_数学_自然科学_专业资料的相关文章

条件选股公式的编写_数学_自然科学_专业资料热门点击